Dyn Status Updates


See upcoming maintenance and any incidents in progress.

DDoS Attack in US West
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted Apr 15, 2018 - 18:09 UTC
Investigating
On April 15th, 2018 around 15:10 UTC, we began mitigating a DDoS attack on Dyn's Infrastructure. Some users may have experienced increased latency in the US West region on the Dyn Managed DNS nameservers.

Customers with any questions are encouraged to reach out to our Technical Support Team.
Posted Apr 15, 2018 - 15:26 UTC