Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Dyn.com Error in Checkout Process
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted Dec 06, 2017 - 22:20 UTC
Investigating
On November 30th, beginning around 15:00 UTC, some customers may be experiencing errors in the checkout process for services purchased through account.dyn.com. Please clear your browser's cookies and reattempt the checkout process. This does not affect automatic renewals of existing services. Our engineers are investigating the issue and we will post updates as they become available.

Customers with questions or concerns are encouraged to reach out to our Customer Support Team.
Posted Dec 06, 2017 - 19:14 UTC
This incident affected: Dyn.com.