Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Dyn.com Verification Prompt
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted Apr 17, 2018 - 19:34 UTC
Investigating
On April 17th 2018, beginning around 18:50 UTC, some customers may have experienced a security prompt logging into dyn.com. After passing validation, users should be able to navigate the site as expected. Our engineers are investigating the issue and we will post updates as they become available.

This is not impacting other Dyn services such as Managed DNS or Email Delivery.

Customers with questions or concerns are encouraged to reach out to our Customer Support Team.
Posted Apr 17, 2018 - 19:15 UTC
This incident affected: Dyn.com.