Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Dyn Managed DNS and Email Portal Service Degradation
Incident Report for Oracle + Dyn
Resolved
As of 16:01 UTC this incident has been resolved.
Posted Nov 24, 2016 - 16:16 UTC
Investigating
On November 24th 2016, beginning around 15:15 UTC, some customers may have experienced problems logging into and navigating within the Dyn Email Delivery Portal and Dyn Managed DNS Portal. Our engineers are investigating the issue and we will post updates as they become available.

Customers with questions or concerns are encouraged to reach out to our Technical Support Team.
Posted Nov 24, 2016 - 15:15 UTC
This incident affected: Dyn Email Delivery (Portal) and Dyn Managed DNS (Portal).