Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Emergency Domain Registration Scheduled Maintenance
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted Sep 18, 2016 - 20:24 UTC
Investigating
On September 18th, 2016, starting around 14:00 UTC, CoCCA began performing routine maintenance on their domain registration platform. During this period, customers may be unable to update, renew or purchase .CX TLD domains through Dyn.

Customers with questions or concerns are encouraged to reach out to our Customer Support team.
Posted Sep 18, 2016 - 15:01 UTC