Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Resolved issue with DNS propagation
Incident Report for Oracle + Dyn
Resolved
On November 24, 2020, between 16:31 and 19:09 UTC, Managed DNS customers making changes to zones which contain ALIAS records, DNSSEC or Policy Steering Services may have experienced delayed propagation of those changes. The issue is now resolved.

Customers with questions are encouraged to reach out to our Technical Support Team.
Posted Nov 24, 2020 - 19:15 UTC