Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Remote Access Device Users Unable to Reset Passwords
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted Jun 14, 2017 - 18:54 UTC
Identified
Starting on June 12th, 2017 at 14:30 UTC, some customers using their D-Link Portal may be experiencing problems resetting their passwords. Our engineers have identified the issue and are working on a fix. We will post updates as they become available.

Customers with questions or concerns are encouraged to reach out to our Technical Support Team.
Posted Jun 12, 2017 - 14:30 UTC