Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Support phone system down
Incident Report for Oracle + Dyn
Resolved
We have resolved the issue with our phone systems.
Posted Apr 13, 2021 - 15:25 UTC
Investigating
Our Dyn product support teams are currently experiencing issues with our phone system and are unable to receive calls. Please reach out through your product portal or email your support team until this is resolved. If you are unsure of your support contact email, please use userhelp@dyn.com.
Posted Apr 12, 2021 - 19:35 UTC