Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Dyn customers unable to create support case
Incident Report for Oracle + Dyn
Resolved
The issue has been resolved now.
Posted Mar 17, 2020 - 12:30 UTC
Identified
Beginning at approximately 04:00 UTC, 17 March 2020 users may experience difficulties submitting a customer support ticket. We are actively working on mitigating the issues. Any additional updates will be posted as they become available.
Posted Mar 17, 2020 - 07:53 UTC
This incident affected: Dyn.com.