Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Dyn Managed DNS and Email Delivery Portal Degradation
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted Sep 21, 2017 - 18:07 UTC
Investigating
On September 21, beginning around 17:28 UTC, some customers may be experiencing delays or errors when interacting with the Dyn Managed DNS and Email Delivery Web Portals. Our engineers are investigating the issue and we will post updates as they become available.

Customers with questions are encouraged to reach out to our Technical Support Team.
Posted Sep 21, 2017 - 17:45 UTC
This incident affected: Dyn Email Delivery (Portal) and Dyn Managed DNS (Portal).