Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Dyn Email Delivery delay in retrieving reporting data
Incident Report for Oracle + Dyn
Resolved
This issue was resolved at 10:06 UTC on July 28, 2020.
Posted Jul 29, 2020 - 00:45 UTC
Monitoring
Dyn engineers have applied a fix and mitigated the issue. We will continue to monitor service health to ensure service stability.
Posted Jul 28, 2020 - 01:53 UTC
Identified
Beginning at approximately 13:00 UTC, July 25, 2020, Dyn Email Delivery customers may have begun to experience degraded performance while retrieving reporting data in their Dyn Email Delivery service. Posting new reporting data was delayed for some customers.
Email sending is not affected
Customers with any questions are encouraged to reach out to our Product Support Team.
Posted Jul 27, 2020 - 01:07 UTC
This incident affected: Dyn Email Delivery (Delivery and Engagement Data).