Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Intermittent Payment Issues For Purchases at Dyn.com
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted May 17, 2016 - 20:26 UTC
Investigating
As of 15:00 UTC on May 17th, 2016, We have discovered that some customers are experiencing difficulties when making purchases through Paypal at Dyn.com. We are working to get these issues resolved as quickly as possible. Updates will be posted as they become available.

Customers experiencing this issue are encouraged to reach out to our Customer Support Team at billing@dyn.com for assistance.
Posted May 17, 2016 - 15:00 UTC
This incident affected: Dyn.com.