Dyn Status Updates


See upcoming maintenance and any incidents in progress.

DynID Enrollment Degradation
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted Mar 19, 2019 - 21:21 UTC
Investigating
On March 19, 2019, beginning around 15:45 UTC, some customers may experience problems enrolling in DynID within our customer portal. No other impact is expected. Our engineers are investigating the issue and updates will be posted as they are available.

Customers with questions or concerns are encouraged to reach out to our Product Support Team.
Posted Mar 19, 2019 - 17:28 UTC
This incident affected: Dyn Email Delivery (Portal) and Dyn Managed DNS (Portal).