Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Billing@dyn.com and billing@dyndns.com are currently unable to receive billing inquiries
Incident Report for Oracle + Dyn
Resolved
The incident has been resolved now. Customers with any questions or concerns are encouraged to reach out to our Product Support Team via support@dyn.com
Posted Feb 24, 2020 - 02:10 UTC
Investigating
We are currently investigating an issue with the Dyn service email address for billing inquiries. Customers who have recently written to our Billing Support Team and did not receive a case creation acknowledgment when sending to billing@dyn.com or billing@dyndns.com are encouraged to resend their request to our support@dyn.com email address to ensure that requests are actioned. Please note that if you did not receive a case creation notice, your email did not reach our support team. We are working to correct this issue and will provide an update once it is resolved.

This incident involves incoming emails to our Billing Support Team only and does not impact any Dyn services.

Customers with any questions are encouraged to reach out to our Product Support Team via support@dyn.com.
Posted Feb 22, 2020 - 01:08 UTC