Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Telephone Provider Issues
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted Jan 12, 2017 - 17:15 UTC
Update
At this time, we would like to update that our US sales team phone number is currently available once again. (1-888-840-3258)
Posted Jan 12, 2017 - 16:09 UTC
Update
At this time, we are working with our provider to remedy the situation. Currently our EMEA sales number is unavailable (+44-127-325-7289). We will post updates as soon as they become available.
Posted Jan 12, 2017 - 16:06 UTC
Investigating
On January 11th, 2017, beginning around 21:45 UTC, our telephone provider began having intermittent issues receiving inbound phone calls to our Sales teams phone number (1-888-840-3258). We are working with our provider to get these issues resolved as quickly as possible. Updates will be posted as they become available.

Customers with sales inquiries are encouraged to contact us via email at sales@dyn.com
Posted Jan 11, 2017 - 21:45 UTC