Dyn Status Updates


See upcoming maintenance and any incidents in progress.

Telephone/Chat Provider Issues
Incident Report for Oracle + Dyn
Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 18:45 UTC
Identified
Our telephone provider continues to experience service degradation which are prevent Dyn Support agent from receiving inbound calls or chats. We will follow-up with further information as available.
Posted Mar 15, 2023 - 17:56 UTC
Investigating
On March 15th, 2023, beginning around 15:25 UTC, our telephone provider began having intermittent issues receiving inbound phone calls to our Technical Support phone numbers and Dyn Self Service (https://account.dyn.com) chat support. We are working with our provider to get these issues resolved as quickly as possible. Updates will be posted as they become available.

Customers with questions are encouraged to reach out to our Product Support Team by email and request a callback if required.
Posted Mar 15, 2023 - 15:42 UTC